Nobby's S-650

SPR

Well-Known Member
I owe you a pint of your home-made beer ! There doesn't appear to be any difference. I shall be sending off for my latest ICP test this week, so it'll be interesting to see what that shows.
You will be fine, Ive just had one back after nearly 5 years and all is well, because there isnt any difference
 

SPR

Well-Known Member
Wow, you've made the leap of faith and got an ICP test! Did you go Triton or ATI?
Triton and all is good. I had one on the big tank as well a month ago, Infact I’ve stopped dosing the coral colours as I don’t think there necessarily needed. The big tank had raised iodine and nickel because of the colours so I’ve stopped adding them

I can show in build if anyone interested
 

Nobbygas

Well-Known Member
And right on time.......My S-650 system was set-up around six months after Shaun's, and lo and behold my first power supply on the lights has packed up ! I've ordered two for now as I'm pretty sure another will drop dead at any time.
 

Nobbygas

Well-Known Member
I was in the local supermarket last week and I noticed they had some fresh Oysters for sale, so I bought one. Got home and prised it open with a knife. I then placed the half-shell containing the Oyster into the tank...........and not one of the fish showed the slightest interest in it. I thought the Trigger at least would be interested because he's a pig who will eat anything, but no.
 

Pancho75

Well-Known Member
And right on time.......My S-650 system was set-up around six months after Shaun's, and lo and behold my first power supply on the lights has packed up ! I've ordered two for now as I'm pretty sure another will drop dead at any time.
Dang, I will have to buy spares, thank you for sharing.
 

Nobbygas

Well-Known Member
Agh, the things we forget about.

When I setup my S-650, I found the power cords for the two lights furthest from the power centre were too short. I contacted Red Sea and they very kindly replaced two of the power packs with ones that had a longer cord.......Moving on, I have just bought two replacement power units, and lo and behold I completely forget about the longer cords needed...agh ! Not a major problem but an irritation. I shall just look for two more with extra long cords.

So I'm getting my tank prepared for the Summer. This means that I have to get the Chiller up and running again. During the Winter I just turn it off as it's not needed. I don't even need the heating part of it as the ambient room temperature keeps the tank at the required level. For this I usually replace the green tubing that goes in/out of the Chiller as they tend to get a lot of gunk in them. I also run a mixture of white vinegar/water through the Chiller for a couple of hours as well to help give the inside a clean. I've also given the UV-C a complete clean, bulb replacement and tubing replaced. Pumps for both were cleaned as well.

Bring on the Summer !
 
  • Like
Reactions: SPR
Top